使用顶点绘制着色器和多边形笔刷轻松混合材质。

描述
此包包含一组专门为与Polybrush一起使用而创建的着色器。

如果要使用Polybrush绘制高级着色器并提高场景质量,则此包适合您。

该包包含每个着色器的两个版本:Lite和Pro着色器。Lite着色器是Pro着色器的简化版本,包含基础层和效果层(可以绘制)。除了基础层和效果层外,Pro着色器还考虑一个甚至两个额外的可绘制层。

在这里找到我们与HD渲染管道兼容的版本。

支持的Unity版本

2022 LTS(默认)

2019 LTS->2021 LTS

 

该文件包括URP和内置着色器。

默认情况下,该包设置为URP渲染管道(自v2022.3起)。请按照通用渲染管道项目文档中的URP设置进行操作。

对于内置RP,删除URP文件夹并解压缩Builtin Polybrush shaders.unitypackage。

包括文件

此包已包含12个着色器。Basic Lite和Pro、高级Standard Pro、Flood和Rainy Puddles Lite和Pro着色器。随着时间的推移,将添加其他着色器(参见下面的列表)。

 

着色器:

每个着色器都有不同的版本(Basic、Lite或Pro)

基本的

标准

洪水

-雨水和水坑

-冰(即将到来)

-冰雪(即将来临)

还有更多